Last week I sent über beta tester Andrew "Spyder" Herron a pre-beta version of FeedDemon 2.5, and among the new features he noticed was a per-feed setting that enables ignoring new items if they're older than a certain number of days (useful for buggy feeds that keep bringing back old items as new).
Andrew made the point that this feature could be a problem when you're away from your computer for a few days - for example, if you set it to five days and then don't update your feeds for a week, you're going to miss stuff. So we decided that it would make more sense to ignore items published N days prior to the last time you updated your feeds.
And I can't for the life of me figure out how to name this feature.
The feature itself took very little time to code, but naming it has taken far too long. The name has to be short enough to fit in the feed properties dialog, yet long enough to effectively describe what it does. And it has use language that's clear to non-geeks.
This sort of thing happens a lot - I spend more time figuring out what to call a feature than I do coding it in the first place.